From a router named R3, you just need to add the redistribution commands under EIGRP and
RIP. Listed in Table 4.4 are the commands:
Routing Protocol Redistribution Commands
Command Meaning
redistribution
Displays a routers table of known or learned destination networks
metric
Sets the parameters for redistribution
bandwidth
Configures the bandwidth used for routing calculations
delay
Sets the delay of the link used for routing calculations
reliability
Not used by default with EIGRP, but sets the reliability of the link used
with routing calculations if administratively set
load
Not used by default with EIGRP, but sets the load of the link used with
routing calculations if administratively set
MTU
Not used by default with EIGRP, but sets the maximum transmission
unit of the link used with routing calculations if administratively set
The commands seem a little convoluted, but once you work through them a few times,
you’ll start to feel more comfortable with redistribution. Take a look:
R3#
config t
R3(config)#
router eigrp 10
R3(config-router)#
redistribute rip ?
metric Metric for redistributed routes
route-map Route map reference
R3(config-router)#
redistribute rip metric ?
<1-4294967295> Bandwidth metric in Kbits per second
R3(config-router)#
redistribute rip metric 10000000 ?
<0-4294967295> EIGRP delay metric, in 10 microsecond units
R3(config-router)#
redistribute rip metric 10000000 20000 ?
<0-255> EIGRP reliability metric where 255 is 100% reliable
R3(config-router)#
redistribute rip metric 10000000 20000 255 ?
<1-255> EIGRP Effective bandwidth metric (Loading) where 255 is 100% loaded
R3(config-router)#
redistribute rip metric 10000000 20000 255 1 ?
<1-65535> EIGRP MTU of the path
R3(config-router)#
redistribute rip metric 10000000 20000 255 1 1500
R3(config-router)#
do show run | begin router eigrp 10
router eigrp 10
redistribute rip metric 10000000 20000 255 1 1500
passive-interface FastEthernet0/0
passive-interface Serial0/0/0
network 10.0.0.0
no auto-summary
!
As you can see, I needed to change RIP’s metric of hop count to match EIGRP’s bandwidth
metric, delay, reliability, load, and MTU. Even though EIGRP may use only bandwidth and
delay of the line by default, when you configure redistribution, you have to configure all metric
values.
The following output shows I’m redistributing EIGRP into RIP and changing the metric to
hop count:
R3(config)#
router rip
R3(config-router)#
redistribute eigrp 10 ?
metric Metric for redistributed routes
route-map Route map reference
R3(config-router)#
redistribute eigrp 10 metric ?
<0-16> Default metric
transparent Transparently redistribute metric
R3(config-router)#
redistribute eigrp 10 metric 1