ISDN-ITU-T Q.921-Q.931-T-1 (1.544Mbps) or E-1 (2.048Mbps)

ISDN is an old but still very viable networking standard that supports voice, data, and
video. It is slowly being replaced by DSL and cable modems. Layer 2 is negotiated by using
the ITU-T Q.921 standard, and layer 3 is negotiated by using the Q.931 standard. The
ISDN reference model is set up with function groups and reference points. The function
groups classify each device in the ISDN network, and the reference points identify the connections
and electrical characteristics between each function group. Many IOS debug and
show commands are available to help you understand and troubleshoot ISDN connections.
The types of connections include dial backup, dial-on-demand routing (DDR), and
Bandwidth on Demand (BoD). There are many ways to set up a connection from one device
to another by using ISDN and analog links. The legacy method uses the physical interface to
specify IP address, dialing properties, and authentication. Dialer profiles provide more flexibility
when using dial backup and other dial-up connections. When using PPP authentication,
both Password Authentication Protocol (PAP) and Challenge Handshake Authentication Protocol
(CHAP) can be used. Some IOS debug and show commands are associated with PPP
negotiation and authentication.





Know the types of ISDN. ISDN comes in two flavors: BRI and PRI. The BRI is a standard that
runs over a 192Kbps circuit, whereas a PRI can run over a T-1 (1.544Mbps) or E-1 (2.048Mbps)
circuit. Know when to use a BRI and when to use a PRI. There are many PRI and BRI ISDN switch
types supported, and you should know which ones require SPIDs and which do not.
Understand the ISDN function groups. You need to know what function the groups NT1,
NT2, TA, LT, ET, TE1, and TE2 provide in the ISDN network.
Know the ISDN reference points. Identify the ISDN reference points of R, S, T, and U. Know
where these reference points are in the ISDN network and between which function groups they
are found.
Understand the two ITU-T Q standards used by ISDN. The Q.921 standard is used to set up
layer 2 between the router and local switch, and the Q.931 standard is used to set up layer 3.
You need to know what these protocols’ structures look like and what happens when a call is
set up and when it is torn down. You should also be familiar with the debug isdn q921 and
debug isdn q931 commands and what to look for in troubleshooting a problem.
Know how to set up dial-on-demand routing (DDR), dial backup, and Bandwidth on Demand
(BoD) by using both legacy and dialer profiles. Dialer profiles are used when you need to set
up a routing protocol over a dial-up connection; the legacy setup is used when a simple pointto-
point connection is needed between two sites. You should know how to set up authentication
and callback when security is needed on a dial-up connection. Multilink is also available when
more bandwidth is needed on a connection.
Know how to set up a channelized interface. You should know how to set up a T-1 or E-1
controller for channelized operation. You need to know the different framing and linecoding
options. The pri-group command is used when setting up a channelized interface to become
an ISDN PRI. The channel-group command is used when an interface or a portion of the interface
is used for dedicated access.

906

Configuring E-1

The E-1 configuration is similar to the T-1 configuration but has a few different parameters:
Framing The E-1 framing types available are crc4 and no-crc4, with australia as an
option. The default is crc4, and it specifies CRC error checking, with no-crc4 specifying
that CRC checking is (surprise!) disabled. The australia framing method is used when configuring
an E-1 in (another surprise!) Australia.
Linecode This is either AMI or HDB3 when configuring an E-1, with HDB3 as the default.
In the following example, we specified slot 0, port 1 on our MIP card, using the crc4 framing
type. The provider has defined HDB3 as the linecode (HDB3 is the default) to match the carrier’s
equipment. For an E-1 PRI circuit, the D channel is 15 so the command pri-group time-slots
1-16 will specify that channels 1 through 15 will be controlled by the D channel (subchannel 15).
Again, remember not to get confused with the channel group and time slot numbering; the channel
group numbers range from 0 to 30, whereas the time slot values range from 1 to 31. Also remember
that channel 15 on the E-1 and channel 23 on the T-1 are for the D channels. However, time
slots 17 to 30 are for a dedicated connection with up to 30 available if purchased:
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#controller E1 1/0
Router(config-if)#framing crc4
Router(config-if)#linecode hdb3
Router(config-if)#pri-group timeslots 1-16
Router(config-if)#channel-group 1 timeslots 17-30 speed 64
Router(config-if)#^Z
Router#
You then need to specify the IP address and encapsulation methods used, just as in the T-1
example:
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface serial1/0:15
Router(config-if)#encapsulation ppp
Router(config-if)#ip address 172.16.30.5 255.255.255.252
Router(config)#interface serial1/0:1
Router(config-if)#encapsulation hdlc
Router(config-if)#ip address 172.16.30.5 255.255.255.252
Router(config-if)#^Z
Router#

Configuring ISDN PRI

The serial links connect into either a private data network or a service provider’s network. Both
the line encoding and the framing must match the service provider’s equipment. To configure
a PRI on a serial link, you must supply the following information:
Channel type Either T-1 or E-1.
Frame type When using a T-1, this can be either D4, sometimes referred to as Super Frame,
or Extended Super Frame (ESF). D4 is the original T-1 frame format and comprises one framing
bit and a DS0 time slot for each channel on the line. ESF comprises 24 D4 frames. As each D4
frame contains a framing bit, an ESF has 24 framing bits that it uses for synchronization (6 bits),
error checking (6-bit cyclic redundancy check), and diagnostic data channel (12 bits).
Linecode This will be either alternate mark inversion (AMI) or binary 8-zero substitution
(B8ZS). B8ZS is typically used in the U.S.; however, most legacy phone systems still use AMI.
Dynamic Multiple Encapsulation Back in the old days, prior to Cisco IOS 12.1, the interface
encapsulation that we used in the previous example—PPP and others such as Frame Relay,
High-Level Data Link Control (HDLC), Link Access Procedure (LAP), and X.25—could support
only one ISDN B channel connection over the entire link, or as in the case of HDLC and
PPP, the entire link needed to use the same encapsulation method. With the Dynamic Multiple
Encapsulation feature, the ISDN B channel becomes a forwarding device, and the D channel is
ignored, thereby allowing different encapsulation types and per-user configuration.
Which T-1 time slots to use By using the pri-group command on your PRI interface, you
can define which time slots will be controlled by the D channel (subchannel 23). You can also
specify dedicated time slots on the same interface with the channel-group number time slot
range command. This will assign the time slots in the range specified, to the subchannel group
of number.
In the following example, we chose to configure slot 1, port 0 of the MIP card in a 7000 router,
and we opted for ESF framing, with B8ZS line coding. Remember not to get confused with the
channel group and time slot numbering; the channel group numbers range from 0 to 23, whereas
the time slot values range from 1 to 24. Also remember that channel 15 on the E-1 and channel 23
on the T-1 are for the D channels. The command pri-group timeslots 12-24 indicates that
the D channel will control time slots 11 through 23 on the PRI circuit. Channel group 1 has six
time slots running at 64Kbps. We could choose up to 24 DS0s but purchased only six from our
provider, with 12 through 24 being controlled with the PRI D channel. Here’s the output:
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#controller T1 1/0
Router(config-if)#framing esf
Router(config-if)#linecode b8zs
Router(config-if)#pri-group timeslots 12-24
Router(config-if)#channel-group 1 timeslots 1-6 speed 64
Router(config-if)#^Z
An IP address and the serial encapsulation method (HDLC is the default) then needs to be
assigned to each interface, as shown in the following example:
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface serial1/0:23
Router(config-if)#encapsulation ppp
Router(config-if)#ip address 172.16.30.5 255.255.255.252
Router(config)#interface serial1/0:1
Router(config-if)#encapsulation hdlc
Router(config-if)#ip address 172.16.30.5 255.255.255.252
Output for the five other B channels (serial/0-2-6) has been omitted to save space.
Router(config-if)#^Z
Router#
When connecting two MIP cards back-to-back, you must specify the clocking on
one controller. This is done with the clock source internal command.

Channelized T-1/E-1 (PRI)

Large businesses typically use point-to-point connections with DSU/CSUs to connect two sites.
In turn, these are connected to low- and high-speed serial interfaces on routers—usually Cisco
routers. The router backplane and the number of interfaces the router can handle determine
how well it supports WAN connections. The Cisco 7000 series of routers supports the Fast
Serial Interface Processor (FSIP), which provides either four or eight serial ports, permitting
the four or eight point-to-point connections to remote offices. Other Cisco routers support the
Multichannel Interface Processor (MIP), which furnishes support for two full T-1/E-1 ports in
the 7000 series and one port in the 4000 series.
ISDN T-1s, which are called Primary Rate Interfaces (PRIs), run at 1.544Mbps. These use 24
channels in contrast to E-1s, which use 31 channels and run at 2.048Mbps. E-1 is mainly used
in Europe, and both T-1 and E-1 are considered wide-area digital transmission schemes.
Each port in the MIP can support 24 DS0 channels of 64Kbps each when using a T-1 interface,
and 31 DS0 channels when using an E-1 interface. The MIP refers to each serial interface
as a channel group; this enables each channel or DS0 to be configured individually. Each channel
has the same characteristics and options as regular serial interfaces.

Testing the Backup

After the configuration, it’s important to test your backup link. You don’t want to wait for an
actual outage before discovering you have made a configuration mistake. You’ll test the backup
by disabling the connected serial interface on R2.
When the test is performed, it takes 11 seconds for the backup line to come out of Standby
mode and another four seconds for layers 1 and 2 to come up. The following router output
shows this. Why would using a dialer interface save you four seconds in this scenario?
00:46:22: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, _
➥changed state to down
00:46:23: %LINK-3-UPDOWN: Interface Serial0, changed state to down
00:46:23: %FR-5-DLCICHANGE: Interface Serial0 - DLCI 202 state changed_
➥to DELETED
00:46:23: %FR-5-DLCICHANGE: Interface Serial0 - DLCI 100 state changed
➥_to DELETED
00:46:23: %FR-5-DLCICHANGE: Interface Serial0 - DLCI 200 state changed
➥_to DELETED
00:46:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0.202,
➥_ changed state to down
00:46:34: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
00:46:34: %LINK-3-UPDOWN: Interface BRI0:2, changed state to down
00:46:34: %LINK-3-UPDOWN: Interface BRI0, changed state to up
00:46:38: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 107 changed to up
00:46:38: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 108 changed to up
00:46:59: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
00:47:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, _
➥changed state to up
00:47:06: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 8358662
00:47:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, _
➥changed state to up
00:47:24: %LINK-3-UPDOWN: Interface Serial0, changed state to up
00:47:24: %FR-5-DLCICHANGE: Interface Serial0 - DLCI 202 state changed_
➥to ACTIVE
00:47:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0.202, _
➥changed state to up
00:48:24: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
00:48:24: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from_
➥unknown, call lasted 85 seconds
00:48:24: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 107_
➥changed to down
00:48:24: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 108_
➥changed to down
00:48:24: %LINK-5-CHANGED: Interface BRI0, changed state to standby mode
00:48:24: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
00:48:24: %LINK-3-UPDOWN: Interface BRI0:2, changed state to down
00:48:25: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, _
➥changed state to down
You should also note in the preceding router output that the backup line dropped one minute
after the primary link came up. Changing the delay between primary failure and activation of
the backup line plus delay between primary recovery and deactivation of the backup line can be
modified by using the backup delay 10 60 command. The first number (10) is how many seconds
to wait before activating the backup interface, and the second number (60) is how many
seconds to stay up once the primary line recovers.
As we stated earlier, it is best to use a dialer profile, or dialer interface, as the backup interface,
so we will show you how this is done. Setting up a dialer profile requires two steps: configuring
the primary interface and configuring the dialer interface. The primary interface needs
only some basic information; for example, take a look at this configuration:

interface BRI0
no ip address
encapsulation ppp
isdn spid1 0835866101 8358661
isdn spid2 0835866301 8358663
dialer pool-member 1
!

Basically, all we did was set up ISDN layers 1 and 2, enable PPP encapsulation, and assign
this interface to dialer pool 1—pretty simple so far.
The next step involves the dialer interface. A dialer interface is virtual, meaning it is not
a physical interface, and you add it by using the global command interface dialer 1.
The connection-specific configuration commands are placed under this interface, including
creation of the dialer pool, phone number to dial, remote device name, interesting traffic,
authentication, and IP address information. Again, it’s not that difficult. Take a look at this
configuration:
interface Dialer1
ip address 192.168.254.2 255.255.255.0
encapsulation ppp
dialer remote-name r3
dialer string 8358662
dialer pool 1
dialer-group 1
ppp authentication chap callin
Note that the callin option on the ppp authentication command indicates authentication
on incoming (received) calls only.
You will notice that the dialer interface goes into Standby but the BRI interface doesn’t. You
can verify this by using the show ISDN status command:
r2#show isdn status
The current ISDN Switchtype = basic-ni
ISDN BRI0 interface
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 109, State = MULTIPLE_FRAME_ESTABLISHED
TEI = 110, State = MULTIPLE_FRAME_ESTABLISHED
Spid Status:
TEI 109, ces = 1, state = 5(init)
spid1 configured, spid1 sent, spid1 valid
Endpoint ID Info: epsf = 0, usid = 1, tid = 1
TEI 110, ces = 2, state = 5(init)
spid2 configured, spid2 sent, spid2 valid
Endpoint ID Info: epsf = 0, usid = 3, tid = 1
Layer 3 Status:
0 Active Layer 3 Call(s)
Activated dsl 0 CCBs = 1
CCB: callid=0x0, sapi=0, ces=1, B-chan=0
Total Allocated ISDN CCBs = 1

service timestamps log uptime
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r2
!
enable password cisco
!
username r3 password 0 cisco
isdn switch-type basic-ni
!
interface Serial0
no ip address
encapsulation frame-relay
no fair-queue
!
interface Serial0.202 point-to-point
backup delay 10 60
backup interface Dialer1
ip address 172.16.34.2 255.255.255.0
frame-relay interface-dlci 202
!
interface BRI0
no ip address
encapsulation ppp
isdn switch-type basic-ni
isdn spid1 0835866101 8358661
isdn spid2 0835866301 8358663
dialer pool-member 1
!
interface Dialer1
ip address 192.168.254.2 255.255.255.0
encapsulation ppp
dialer remote-name r3
dialer string 8358662
dialer pool 1
dialer-group 1
ppp authentication chap
!

ip classless
ip route 0.0.0.0 0.0.0.0 172.16.34.3
ip route 0.0.0.0 0.0.0.0 192.168.254.3 210
!
dialer-list 1 protocol ip permit
!
end
r2#
r3#show run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r3
!
enable password cisco
!
username r2 password 0 cisco
ip subnet-zero
!
isdn switch-type basic-ni
!
interface FastEthernet0/0
ip address 192.168.252.3 255.255.255.255
no ip directed-broadcast
!
interface Serial0/0
no ip address
no ip directed-broadcast
encapsulation frame-relay
no ip mroute-cache
frame-relay lmi-type cisco
!

interface Serial0/0.203 point-to-point
ip address 172.16.34.3 255.255.255.0
no ip directed-broadcast
frame-relay interface-dlci 203
!
interface BRI0/0
ip address 192.168.254.3 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer map ip 192.168.254.2 8358661
dialer-group 1
isdn switch-type basic-ni
isdn spid1 0835866201 8358662
isdn spid2 0835866401 8358664
ppp authentication chap
dialer hold-queue 75
!
ip classless
ip route 172.16.2.0 255.255.255.0 172.16.34.2
ip route 172.16.2.0 255.255.255.0 192.168.254.2 210
!
dialer-list 1 protocol ip permit
!
end

As you can see, the configuration is not that complex. Having a good working knowledge of
this will help you solve many dial backup scenarios. Of course, you can make this as complex
as you’d like; we kept this example fairly simple as an illustration.
The command dialer-list creates the interesting traffic. The command dialer-group
assigns the dialer list to an interface. The numbers must match. In the previous example, both
the dialer list and the dialer group are 1. The dialer hold-queue command creates a buffer
for incoming interesting traffic that is waiting for the BRI to be dialed. The 75 means is that if
75 interesting packets arrive on queue before the interface comes up, the 76th and subsequent
will be dropped until the line comes up and the queue gets some relief.

Bandwidth on Demand

What do you do if you have more traffic than bandwidth? Wouldn’t it be great if you could pull
your magic router wand out and make the traffic go faster? You can approximate this magic by
using Bandwidth on Demand.

Bandwidth on Demand (BoD) is an interface-only command, meaning you cannot apply it
to a subinterface. Here is the syntax to assign a backup load to an interface:
backup load {enable-threshold | never} {disable-load | never}
The enable threshold load is the percentage of interface load where you want the additional
bandwidth dialed up. The disable load is the percentage of interface load where you want the
extra bandwidth dropped. At what point is the circuit congested enough to need extra bandwidth?
Some people say 75 percent; yet others say queuing is needed. You will probably have
to figure this out based on corporate policy, cost, sensitivity to slow responsiveness, and so on.
Because BoD is a dial-up feature, you might incur additional long-distance costs, so be careful
about setting your thresholds.
Configuring BoD is almost the same as configuring dial backup, except you’re replacing the
amount of backup delay with the amount of backup threshold. Here is an example:
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface serial0
Router(config-if)#backup interface BRI0
This configuration sets the interface serial0 to use interface BRI0 as a backup as the main
interface goes down. The following configuration shows how to configure the backup delay and
the backup load:

Router(config-if)#backup ?
delay Delays before backup line up or down transitions
interface Configure an interface as a backup
load Load thresholds for line up or down transitions
Router(config-if)#backup delay ?
<0-4294967294> Seconds
never Never activate the backup line
Router(config-if)#backup delay 10 ?
<0-4294967294> Seconds
never Never deactivate the backup line
Router(config-if)#backup delay 10 60
The previous configuration sets the backup delay to 10 seconds and 60 seconds. This means
that the backup interface will not dial until serial0 is down for 10 seconds, and it will drop the link
after the serial link is back up for 60 seconds. The backup load command syntax is as follows:
Router(config-if)#backup load ?
<0-100> Percentage

never Never activate the backup line
Router(config-if)#backup load 75 ?
<0-100> Percentage
never Never deactivate the backup line
Router(config-if)#backup load 75 35
Router(config-if)#^Z
Router#
This command sets the router to dial the ISDN BRI0 interface if the bandwidth reaches a
maximum of 75 percent and then to drop the link after the bandwidth is back at 35 percent.
The interface configuration is shown next:
Router#show run
[output cut]
interface Serial0
backup delay 10 60
backup interface BRI0
backup load 75 35
ip address 10.53.69.69 255.255.255.0
no ip directed-broadcast
--More—

Setting Up Dial Backup

Your first project is setting up dial backup on the routers. You’ll keep this fairly basic. R2
will call R3 when serial 0.202 goes down. The interesting traffic you’ll designate is all IP.
You will not use a routing protocol, so you’ll have to use a floating static route. Typically,
floating static routes are used with DDR because they can be set to a higher administrative
distance than the routing protocol being used. This enables the router to automatically
bring up the BRI line if the main serial line were to drop.
In the following configuration, you’ll issue a show isdn status command on Router 2 to
verify that the interface configuration is working correctly:

r2#show isdn status
The current ISDN Switchtype = basic-ni
ISDN BRI0 interface
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 100, State = MULTIPLE_FRAME_ESTABLISHED
TEI = 101, State = MULTIPLE_FRAME_ESTABLISHED
Spid Status:
TEI 100, ces = 1, state = 5(init)
spid1 configured, spid1 sent, spid1 valid
Endpoint ID Info: epsf = 0, usid = 1, tid = 1
TEI 101, ces = 2, state = 5(init)
spid2 configured, spid2 sent, spid2 valid
Endpoint ID Info: epsf = 0, usid = 3, tid = 1
Layer 3 Status:
0 Active Layer 3 Call(s)
Activated dsl 0 CCBs = 1
CCB: callid=0x0, sapi=0, ces=1, B-chan=0
Total Allocated ISDN CCBs = 1
As you can see, layers 1 and 2 are up, you are using TEI 100 and 101, and the SPIDs and dialed
numbers (DNs) are valid. This is one of the most important commands you can use. If the SPIDs
are invalid or the configuration is wrong, you will see it in the show isdn status command.
Now you’ll issue the backup interface bri0 command under serial 0.202. This tells the
interface s0.202 to use interface BRI0 if the serial interface loses DCD (data carrier detect),
which means the link is down:
r2(config)#interface serial0.202
r2(config-subif)#backup interface bri0
r2(config-subif)#
%ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 100 changed to down
%ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 101 changed to down
%LINK-5-CHANGED: Interface BRI0, changed state to standby mode
%LINK-3-UPDOWN: Interface BRI0:1, changed state to down
%LINK-3-UPDOWN: Interface BRI0:2, changed state to down
As you can see, this command places the main interface in Standby mode, effectively turning
the interface down. This deactivates layer 1 on the BRI0 interface. This can be verified by issuing
a show ISDN status command at the router prompt:
r2#show ISDN status
The current ISDN Switchtype = basic-ni
ISDN BRI0 interface
Layer 1 Status:
DEACTIVATED
Layer 2 Status:
Layer 2 NOT Activated
Spid Status:
TEI Not Assigned,ces = 1, state = 1(terminal
down)
spid1 configured,spid1 NOT sent,spid1 NOT
valid
TEI Not Assigned,ces = 2, state = 1(terminal
down)
spid2 configured,spid2 NOT sent,spid2 NOT
valid
Layer 3 Status:
0 Active Layer 3 Call(s)
Activated dsl 0 CCBs = 0
Total Allocated ISDN CCBs = 0

Using the physical BRI interface as a backup can cause problems because the BRI interface
appears to be disconnected to the service provider. There is no way to verify that the ISDN BRI
circuit is in proper working order unless you remove it as a backup interface. This is why it’s
best to use a dialer interface as the backup and not the physical ISDN BRI interface, which is
illustrated later in this chapter.

Dial Backup

Dial backup, dial-on-demand routing (DDR), and Bandwidth on Demand (BoD) all use the
same basic interface configuration. Dial backup and BoD use the interface backup commands
to determine if, when, and how long an interface is to be activated. DDR is used for a temporary
dial-up connection from a branch or home office.
Time to do some design work: Using Figure 26.10, you’ll design and configure both legacy
and dialer interfaces. For the sake of this project, you’ll assign some addresses to the
interfaces on R2 and R3 in the figure. Add any additional configuration required to complete
the project. The following list of addresses will give you a starting point. Here is a list
of the addresses you’ll use.
R2 - To0 172.16.2.0/24
R3 - E0/0 192.168.252.0/24
ISDN cloud 192.168.254.0/24
Frame cloud 192.168.123.0/24
Frame Relay
ISDN
To0
R2
E0/0
S0/0
R3
BRI0 BRI0/0
ISDN Information
Network diagram
R2 SPID 1 0835866101 DN 8358661
R2 SPID 2 0835866301 DN 8358663
R3 SPID 1 0835866201 DN 8358662
R3 SPID 2 0835866401 DN 8358664
Switchtype is National 1.

Verifying the ISDN Operation

The following commands can be used to verify legacy DDR and ISDN:
ping and telnet These are great IP tools for any network. However, your interesting traffic
must dictate that ping and telnet are acceptable as interesting traffic to bring up a link.
After a link is up, you can ping or telnet to your remote router regardless of your interesting
traffic lists.
show dialer This command gives good diagnostic information about your dialer and shows
the number of times the dialer string has been successfully connected, the idle-timeout values
of each B channel, the length of the call, and the name of the router to which the interface is
connected.
show isdn active This command shows the number called and whether a call is in progress.
show isdn status A good command to use before you try to dial, this shows whether your
SPIDs are valid and whether you are connected and communicating with layers 1 through 3 to
the provider’s switch.
show ip route A popular Cisco diagnostics command, this shows all routes that the router
currently knows about.
debug isdn q921 This command is used to see layer 2 information only between the router
and the service provider’s ISDN switch.
debug isdn q931 This command is like debug isdn q921 but is used to see layer 3 information,
including call setup and teardown between the access server and the provider’s
ISDN switch.
debug dialer This command gives you call setup and teardown activity from the dialer’s
standpoint.
isdn disconnect interface bri0 This clears the interface and drops the current connection if
one exists. Performing a shutdown on the interface can give you the same results.