Using HSRP for Home Agent Redundancy 25

Using HSRP for Home Agent Redundancy

Problem

You appetite to set up bombastic Home Agents to advance arrangement availability for your Adaptable Nodes.

Solution

For this recipe, we charge configure two about identical Home Agent routers. Actuality is the agreement of the aboriginal one:

RouterHome1#configure terminal

Enter agreement commands, one per line. End with CNTL/Z.

RouterHome1(config)#interface FastEthernet0/0

RouterHome1(config-if)#ip abode 192.168.9.2 255.255.255.0

RouterHome1(config-if)#standby 1 ip 192.168.9.1

RouterHome1(config-if)#standby 1 name HA-GROUP

RouterHome1(config-if)#exit

RouterHome1(config)#router mobile

RouterHome1(config-router)#exit

RouterHome1(config)#router eigrp 99

RouterHome1(config-router)#redistribute mobile

RouterHome1(config-router)#network 192.168.9.0

RouterHome1(config-router)#network 192.168.10.0

RouterHome1(config-router)#default-metric 10000 10 255 1 1500

RouterHome1(config-router)#no auto-summary

RouterHome1(config-router)#exit

RouterHome1(config)#ip adaptable home-agent abode 192.168.9.1

RouterHome1(config)#ip adaptable home-agent back-up HA-GROUP virtual-network

RouterHome1(config)#ip adaptable virtual-network 192.168.10.0 255.255.255.0

RouterHome1(config)#ip adaptable host 192.168.10.1 192.168.10.254 virtual-network 192.168.10.0 255.255.255.0

RouterHome1(config)#ip adaptable defended home-agent 192.168.9.3 spi 100 key ascii cisco

RouterHome1(config)#ip adaptable defended host 192.168.10.110 spi 100 key ascii cookbook

RouterHome1(config)#ip adaptable defended host 192.168.10.111 spi 100 key ascii cookbook

RouterHome1(config)#ip adaptable defended host 192.168.10.112 spi 100 key ascii cookbook

RouterHome1(config)#ip adaptable defended host 192.168.10.113 spi 100 key ascii cookbook

RouterHome1(config)#ip adaptable defended host 192.168.10.114 spi 100 key ascii cookbook

RouterHome1(config)#ip adaptable defended host 192.168.10.115 spi 100 key ascii cookbook

RouterHome1(config)#end

RouterHome1#

And actuality is the additional Home Agent router:

RouterHome2#configure terminal

Enter agreement commands, one per line. End with CNTL/Z.

RouterHome2(config)#interface FastEthernet0/0

RouterHome2(config-if)#ip abode 192.168.9.3 255.255.255.0

RouterHome2(config-if)#standby 1 ip 192.168.9.1

RouterHome2(config-if)#standby 1 name HA-GROUP

RouterHome2(config-if)#exit

RouterHome2(config)#router mobile

RouterHome2(config-router)#exit

RouterHome2(config)#router eigrp 99

RouterHome2(config-router)#redistribute mobile

RouterHome2(config-router)#network 192.168.9.0

RouterHome2(config-router)#network 192.168.10.0

RouterHome2(config-router)#default-metric 10000 10 255 1 1500

RouterHome2(config-router)#no auto-summary

RouterHome2(config-router)#exit

RouterHome2(config)#ip adaptable home-agent abode 192.168.9.1

RouterHome2(config)#ip adaptable home-agent back-up HA-GROUP virtual-network

RouterHome2(config)#ip adaptable virtual-network 192.168.10.0 255.255.255.0

RouterHome2(config)#ip adaptable host 192.168.10.1 192.168.10.254 virtual-network 192.168.10.0 255.255.255.0

RouterHome2(config)#ip adaptable defended home-agent 192.168.9.2 spi 100 key ascii cisco

RouterHome2(config)#ip adaptable defended host 192.168.10.110 spi 100 key ascii cookbook

RouterHome2(config)#ip adaptable defended host 192.168.10.111 spi 100 key ascii cookbook

RouterHome2(config)#ip adaptable defended host 192.168.10.112 spi 100 key ascii cookbook

RouterHome2(config)#ip adaptable defended host 192.168.10.113 spi 100 key ascii cookbook

RouterHome2(config)#ip adaptable defended host 192.168.10.114 spi 100 key ascii cookbook

RouterHome2(config)#ip adaptable defended host 192.168.10.115 spi 100 key ascii cookbook

RouterHome2(config)#end

RouterHome2#

The configurations of the Adaptable Router and the Foreign Agent router are identical to those credible in antecedent recipes in this chapter.

Discussion

If you plan to configure a ample Adaptable IP infrastructure, again a accustomed architecture would be to accept a centralized Home Agent router by application virtual-networks to abutment a ample basin of Adaptable Nodes. In this design, it bound becomes credible that the Home Agent router itself is a austere audible point of abortion for the absolute Adaptable IP network. Fortunately, Cisco provides a way to accomplish the Home Agent redundant.

In this recipe, we adapt the Home Agent agreement apparent in Compound 24.2 to acquiesce you to use a brace of bifold bombastic Home Agent routers. In this example, the two routers are configured in an Active-Standby relationship, so that all cartage uses either one router or the other. Later in this recipe, we will altercate agency to accomplish this an Active-Active accord instead.

In Compound 24.2, we configured the Home Agent abode on a Loopback interface. The acumen for this was simple. Because the tunnels abolish on this address, we capital to accomplish abiding that it was consistently available. Now, however, we appetite to be able to cast our tunnels to the advancement Home Agent router, which agency that we charge to put it on a concrete interface:

RouterHome1(config)#interface FastEthernet0/0

RouterHome1(config-if)#ip abode 192.168.9.2 255.255.255.0

RouterHome1(config-if)#standby 1 ip 192.168.9.1

RouterHome1(config-if)#standby 1 name HA-GROUP

We accept configured HSRP on this interface and assigned the accumulation name HA-GROUP to it. The HSRP basic IP abode for this accumulation is the Home Agent address. On the added router, we accept configured a altered concrete IP address, but the aforementioned basic abode and HSRP group:

RouterHome2(config)#interface FastEthernet0/0

RouterHome2(config-if)#ip abode 192.168.9.3 255.255.255.0

RouterHome2(config-if)#standby 1 ip 192.168.9.1

RouterHome2(config-if)#standby 1 name HA-GROUP

This way, the basic abode is accessible if this Ethernet interface is accessible on either router. Please accredit to Affiliate 22 for added advice on HSRP.

The blow of the Home Agent agreement is appreciably agnate to what we ahead saw in Compound 24.2. So we will aloof attending at the differences, and there are two:

RouterHome1(config)#ip adaptable home-agent back-up HA-GROUP virtual-network

RouterHome1(config)#ip adaptable defended home-agent 192.168.9.3 spi 100 key ascii cisco

These two new commands do two things. The aboriginal one assembly the HSRP group, HA-GROUP, with the IP Mobility Home Agent and configures it to abutment a basic network. The additional one configures a aegis affiliation and affidavit key for the accord amid the two bombastic Home Agents. This is analytical because it is this that allows the two routers to allotment advice about the IP Mobility bindings.

To configure an Active-Active accord amid the two Home Agents, it is all-important to configure two audible Home Agent addresses. One accumulation of Adaptable Nodes will use the aboriginal Home Agent address, and addition accumulation will use the additional address.

First, the interface agreement charge be afflicted to abutment two HSRP groups with altered names and altered basic IP addresses:

RouterHome1(config)#interface FastEthernet0/0

RouterHome1(config-if)#ip abode 192.168.9.2 255.255.255.0

RouterHome1(config-if)#standby 1 ip 192.168.9.1

RouterHome1(config-if)#standby 1 antecedence 110

RouterHome1(config-if)#standby 1 preempt

RouterHome1(config-if)#standby 1 name HA-GROUP

RouterHome1(config-if)#standby 2 ip 192.168.9.5

RouterHome1(config-if)#standby 2 antecedence 90

RouterHome1(config-if)#standby 2 preempt

RouterHome1(config-if)#standby 2 name HA-GROUP2

RouterHome1(config-if)#exit

Then the additional router is the same, but with a altered concrete abode and altered HSRP antecedence values:

RouterHome2(config)#interface FastEthernet0/0

RouterHome2(config-if)#ip abode 192.168.9.3 255.255.255.0

RouterHome2(config-if)#standby 1 ip 192.168.9.1

RouterHome2(config-if)#standby 1 antecedence 90

RouterHome2(config-if)#standby 1 preempt

RouterHome2(config-if)#standby 1 name HA-GROUP

RouterHome2(config-if)#standby 2 ip 192.168.9.5

RouterHome2(config-if)#standby 2 antecedence 110

RouterHome2(config-if)#standby 2 preempt

RouterHome2(config-if)#standby 2 name HA-GROUP2

RouterHome2(config-if)#exit

We accept configured HSRP priorities so that during accustomed operation, the aboriginal router will be alive for the aboriginal basic IP abode and the additional router will be alive for the additional address. We accept additionally configured the accroach keyword on both groups so that if one of the routers does fail, they will acknowledgment to the adapted Active-Active accord afterwards it recovers. Please accredit to Affiliate 22 for added advice on this option.

Then we artlessly accept to configure the routers to acquaint the additional basic IP abode as a Home Agent address:

RouterHome1(config)#ip adaptable home-agent back-up HA-GROUP virtual-network abode 192.168.9.1

RouterHome1(config)#ip adaptable home-agent back-up HA-GROUP2 virtual-network abode 192.168.9.5

And, finally, we charge configure some of our Adaptable Nodes to point to the aboriginal abode and some to point to the additional abode for their corresponding Home Agents.

See Also