Local Breadth Mobility

Local Breadth Mobility

Problem

You appetite to set up Bounded Breadth Advancement to acquiesce accessories to roam throughout your network.

Solution

In this example, the adrift accessory will accept a statically configured abode in the 192.168.10.0/24 range. We accept to configure the home router to use Proxy ARP for adaptable nodes, acceptance added locally affiliated accessories in the aforementioned ambit to acquaint clearly with the adrift device:

RouterHome#configure terminal

Enter agreement commands, one per line. End with CNTL/Z.

RouterHome(config)#interface FastEthernet0/0

RouterHome(config-if)#ip abode 192.168.10.1 255.255.255.0

RouterHome(config-if)#ip proxy-arp

RouterHome(config-if)#ip adaptable arp

RouterHome(config-if)#exit

RouterHome(config)#router eigrp 99

RouterHome(config-router)#network 192.168.10.0

RouterHome(config-router)#default-metric 10000 10 255 1 1500

RouterHome(config-router)#redistribute mobile

RouterHome(config-router)#no auto-summary

RouterHome(config-router)#exit

RouterHome(config)#end

RouterHome#

Then we accept to configure the adopted router, which supports the arrangement articulation breadth our adrift bulge briefly finds itself:

RouterForeign#configure terminal

Enter agreement commands, one per line. End with CNTL/Z.

RouterForeign(config)#interface FastEthernet0/0

RouterForeign(config-if)#ip abode 192.168.110.1 255.255.255.0

RouterForeign(config-if)#ip proxy-arp

RouterForeign(config-if)#ip adaptable arp

RouterForeign(config-if)#exit

RouterForeign(config)#router eigrp 99

RouterForeign(config-router)#network 192.168.100.0

RouterForeign(config-router)#default-metric 10000 10 255 1 1500

RouterForeign(config-router)#redistribute mobile

RouterForeign(config-router)#no auto-summary

RouterForeign(config-router)#exit

RouterForeign(config)#end

RouterForeign#

Discussion

As this archetype shows, there are two accomplish to configuring Bounded Breadth Mobility. The aboriginal is to configure the ip adaptable arp command on all of the interfaces that will abutment adrift accessories either as home or adopted networks:

RouterForeign(config)#interface FastEthernet0/0

RouterForeign(config-if)#ip adaptable arp

This command has two functions. On the home network, it tells the router to use Proxy ARP to abutment associates of the bounded abode ambit that are represented by a host avenue in the acquisition table. On the adopted network, it tells the router to actualize an ARP table access and a host avenue whenever it sees packets from accessories that don't accord to this subnet.

We additionally absolutely accredit Proxy ARP on the interface, in case it has been disabled:

RouterForeign(config)#interface FastEthernet0/0

RouterForeign(config-if)#ip proxy-arp

The additional footfall is to redistribute these adaptable host routes into the Interior Gateway Protocol:

RouterForeign(config)#router eigrp 99

RouterForeign(config-router)#network 192.168.100.0

RouterForeign(config-router)#default-metric 10000 10 255 1 1500

RouterForeign(config-router)#redistribute mobile

In this example, we accept acclimated EIGRP as our IGP, but we could accept acclimated RIP, IS-IS or OSPF aloof as easily. We could alike accept acclimated BGP, although we attention that accomplishing so could be alarming if you don't ascendancy all of the accessories that are demography allotment in BGP. This is because the Bounded Breadth Advancement affection will assignment anxiously alone if every router can see both the avenue for the abounding subnet prefix and the host avenue for the adrift device. In BGP networks, it is almost accepted to try to save arrangement and router assets by clarification out acutely continued prefixes like host networks.

For the aforementioned reason, we accept absolutely disabled EIGRP's auto-summarization affection in this example.

You will apprehension that we accept absolutely configured both the home and adopted routers about identically. In actuality we didn't charge to use the redistribute adaptable command on the home router because alone the adopted router will absolutely be acknowledging adrift end devices. However, in a added accepted bearings it is acceptable that the home router will additionally serve as a adopted router some of the time. So, because there is about no aerial in configuring this adaptable host avenue redistribution back it's not used, we advance configuring it on all of the routers that will be acknowledging Bounded Breadth Mobility.

There are a few simple options accessible with Bounded Breadth Mobility. The ip adaptable arp command accepts arguments to change how continued the router keeps bare adaptable ARP entries:

RouterForeign(config)#interface FastEthernet0/0

RouterForeign(config-if)#ip adaptable arp timers 3 9

The aboriginal after altercation actuality is a keepalive timer, which specifies in account how generally to accelerate ARP packets to see if the adaptable accessory is still there. The additional cardinal is a authority time. This is the breadth of time, in minutes, that the router will advance the ARP access for a adaptable accessory after seeing any cartage from this device. Cisco recommends authoritative the authority time at atomic three times the keepalive time. The absence ethics are 5 account and 15 minutes, respectively.

Note that because these abeyance periods are almost long, this band-aid is not acceptable for situations involving alive roaming. In fact, it would be faster in such situations to use DHCP. It's advantageous to bethink that Cisco developed the Bounded Breadth Advancement affection primarily to be acclimated as a acting acting for DHCP. Please accredit to Chapter 20 for added advice on DHCP.

The ip adaptable arp command additionally allows you to specify an ACL to bind which off-segment antecedent addresses the router is accommodating to support:

RouterForeign(config)#interface FastEthernet0/0

RouterForeign(config-if)#ip adaptable arp access-group 15

RouterForeign(config-if)#exit

RouterForeign(config)#access-list 15 admittance 192.168.10.0 0.0.0.255

RouterForeign(config)#access-list 15 abjure any

There are two advantageous appearance commands with Bounded Breadth Mobility. The aboriginal is appearance ip arp, which shows the ARP cache, including any addresses abstruse by agency of this feature:

RouterForeign#show ip arp FastEthernet0/0

Protocol Abode Age (min) Hardware Addr Blazon Interface

Internet 192.168.110.1 - 000e.d7d6.1060 ARPA FastEthernet0/0

Internet 192.168.10.109 1 00b0.64ab.0580 ARPA FastEthernet0/0

Internet 192.168.110.9 21 0000.0c75.c684 ARPA FastEthernet0/0

RouterForeign#

It is additionally advantageous to attending at the acquisition table for any Adaptable or host routes. On the adopted router, they will appearance up as Adaptable routes:

RouterForeign#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA alien blazon 1, N2 - OSPF NSSA alien blazon 2

E1 - OSPF alien blazon 1, E2 - OSPF alien blazon 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - applicant default, U - per-user changeless route

o - ODR, P - alternate downloaded changeless route

Gateway of aftermost resort is not set

C 192.168.110.0/24 is anon connected, FastEthernet0/0

192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks

M 192.168.10.109/32 [3/1] via 192.168.10.109, 00:17:59, FastEthernet0/0

D 192.168.10.0/24 [90/2172416] via 192.168.55.11, 00:29:43, Serial0/0

C 192.168.55.0/24 is anon connected, Serial0/0

RouterForeign#

On any added router, they will arise artlessly as alien redistributed host routes:

RouterHome#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA alien blazon 1, N2 - OSPF NSSA alien blazon 2

E1 - OSPF alien blazon 1, E2 - OSPF alien blazon 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - applicant default, U - per-user changeless route

o - ODR, P - alternate downloaded changeless route

Gateway of aftermost resort is not set

D 192.168.110.0/24 [90/2172416] via 192.168.55.12, 00:31:43, Serial0/0

192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks

D EX 192.168.10.109/32 [170/2172416] via 192.168.55.12, 00:18:19, Serial0/0

C 192.168.10.0/24 is anon connected, FastEthernet0/0

C 192.168.55.0/24 is anon connected, Serial0/0

RouterHome#

Note that if you accept a lot of accessories adrift application this method, again your acquisition tables will accept a lot of host routes. Normally, we try to accumulate acquisition tables baby by application appearance such as avenue summarization to advice with acquisition agreement aggregation and to advance avenue lookup performance. This affection works adjoin such mechanisms, and appropriately doesn't calibration well. In general, we adopt DHCP for this blazon of semistatic mobility.

See Also