Configuring DSL CPE-Configuring PPPoE CPE

Configuring DSL CPE
When a CPE router is used as the PPP client, it must be configured. The
configuration will differ depending on whether you are using PPPoE or
PPPoA. PPPoE can be used with an Ethernet or an ATM interface on the
router connecting to the DSL network. An Ethernet interface is used if the
router connects to a DSL modem; an ATM interface is used if the router
connects directly to the DSL network. A dialer interface must also be
created and configured with PPP parameters.
Configuring PPPoE CPE
The following tasks must be completed to configure a CPE router with for
PPPoE:
1. Configure the internal and external interfaces.
2. Configure a dialer interface.
3. Configure NAT/PAT.
4. Configure the router to act as a DHCP server.
5. Configure a default route.
First, configure the internal Ethernet interface with an IP address. It will be
the default gateway for the users. Also, configure it as the inside interface for
NAT.
Do not put an IP address on the external Ethernet interface. Enable PPPoE
on it, and assign it to a PPPoE client dialer pool. The final configuration on
the two Ethernet interfaces should be similar to that shown in Example 2-1.
Example 2-1 Configuring Ethernet Interfaces for PPPoE
interface FastEthernet0/0
description DSL interface
no ip address
pppoe enable
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
description Internal interface
ip address 172.16.1.1 255.255.255.0
ip nat inside
If the external interface is ATM, the configuration changes slightly. You must
configure the ATM permanent virtual circuit (PVC) information and assign
the interface to a PPPoE client dialer pool. Leave the DSL operating mode at
its default to auto-detect the correct modulation, as shown in Example 2-2.
Example 2-2 Configuring an ATM Interface for PPPoE
interface ATM1/0
description DSL interface
no ip address
dsl operating-mode auto
pvc 1/100
pppoe-client dial-pool-number 1
Second, configure a dialer interface and assign it to the same dialer pool as
the Ethernet interface. Give it a PPP encapsulation and configure the PPP
parameters on it. Make it the NAT outside interface. Limit the maximum
transmission unit (MTU) size to 1492 bytes, to allow for the PPP and
Ethernet headers. Because DSL is an always-on connection, a dialer list is
not required. Your configuration should look similar to Example 2-3. Verify
PPP operation with the show ppp session command. You can also debug
PPP with the commands debug ppp authentication and debug ppp negotiation.
Example 2-3 Configuring a Dialer Interface for PPPoE
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap
ppp chap password dslpass
Next, configure the router to do NAT or PAT. NAT translates one internal
address to one external one. PAT can translate multiple internal addresses to
one external one. Most residential and SOHO subscribers use PAT. To
configure it, identify the traffic that must be translated using an access list.
Then tell the router to translate those IP addresses to the IP address of the
dialer interface, and to “overload” that external IP address. The overload
command causes the router to use PAT. Be sure to designate the inside and
outside interfaces (see Example 2-1 for those commands.) PAT configuration
is done in global command mode, and shown in Example 2-4.
Verify your NAT/PAT operation with the show ip nat translations
command.
Example 2-4 Configuring NAT/PAT
access-list 100 permit ip 172.16.1.0 0.0.0.255 any
!
ip nat inside source list 100 interface Dialer1 overload
The next task is to configure the router to serve IP addresses to internal
hosts. To set up basic DHCP, create a pool of addresses for assigning to
clients, specify the clients’ default gateway, and import the DNS information
obtained from the DSL provider via PPP. Example 2-5 shows what this
might look like. On the router, verify IP address assignment using the
command show ip dhcp binding. On a Windows-based user computer,
verify the IP address using the DOS command ipconfig /all.
Example 2-5 Configuring a Router as a DHCP Server
ip dhcp pool Users
import all
network 172.16.1.0 255.255.255.0
default-router 172.16.1.1
Finally, configure a static default route. It should point to the dialer interface
rather than an IP address, as shown in Example 2-6.
Example 2-6 Configuring a Static Default Route
ip route 0.0.0.0 0.0.0.0 Dialer1